Jun 27, 2019, 05:21 am

News:

Please, come on in and check things out. It would be our pleasure :)


PC stopped working

Started by Lesmond, Dec 27, 2018, 08:51 am

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Lesmond

Dec 27, 2018, 08:51 am Last Edit: Dec 28, 2018, 06:35 pm by Bigguy
So christmas eve morning I turned on my desktop PC and it would not power up at all, so I'm thinking PSU has gone! I took the PSU out to test and the fan spins up!

So I put it back in the case and tried to turn it on again, and noticed the power switch was a bit tight, so I presses it real hard and PC turns on, I'm thinking yes we good.... plugs all my monitors and k/b mouse back in, starts it up again. it turns on but nothing else works, no screens nothing, the hdd lights flashing, but thats it!! :(

So is it the mobo? or something else I dont know..

at the moment I'm on my old HP Comapac with windows 7  :blsh

Anyone have an idea what might be the problem?

Bigguy

Sounds like a psu problem to me. They will go faster than anything else on the board. It probably blew a rail, this is why it still has a bit of power but not enough to do anything.

Lesmond

I dont want to go out and buy a new PSU if its not that, I cant afford one atm anyway :(

Someone else said
Quote from: undefinedminimize everything off take drives out etc just leave 1 stick ram - see if boots bios

if psu is the issue - when u first boot thats when the most amps are pulled so take all off first to just mobo with ram (minimize to what can)

Bigguy

Do you or maybe some friends have an extra lying around you can test with. ??

Ronald

Here is a couple of ways to check if the PSU is good





I got some extra Power Supply units, which one you got, maybe I have one..

Ronald

You might also trying to reseat the ram, make sure nothing loose inside..

Last time I had this happen to me it was the motherboard..

Got any beeps coming from the tower..

Bigguy

Nothing should be loose inside unless there is a lot of vibration from something that was not seated right in the first place. It is always a good idea to make sure all is seated and connected right though. You say the hard drive is flashing... so it is running. Which means the psu is under stress when you power it up....I would almost unhook the drive and see if the video works. If the video and the drive will not work at the same time I would think it is the psu. :tc

Lesmond

@Ronald Thats how I tested the PSU with the wire, and is spun up out the case.

@Bigguy not had chance to test it fully, hopefully get to it over the weekend.

Thanks Guys for the help, I'll keep you posted :good

Lesmond

PC back up and running, seems it was a sata cable shorted!!

[attach name=sata.jpg type=image/jpeg]382[/attach]

Ronald

Quote from: Lesmond on Dec 28, 2018, 02:23 pmPC back up and running, seems it was a sata cable shorted!!

[attach name=sata.jpg type=image/jpeg]382[/attach]

Good pays to check things out first..

Lesmond

process of elimination ;)

Bigguy

Glad to hear that is fixed for you and it was something small. :)

Skhilled